Issue in the Subsystem to System Add on (Capella 1.3)

Hi,
I am using Capella 1.3 for model based systems engineering in my company. I am facing an issue with the Subsystem to System transition tool. I downloaded the dropin version of the add on, and extracted it into the dropin folder. After that , I restarted Capella, opened a model, and right clicked a logical component. I got the option ‘System to Sub system Transition’, and the options ‘Vertical’ and ‘Horizontal’. However, after I clicked on ‘Vertical->SA’, a dialog box appears saying ‘Progress Information- Operation in progress’, and this window disappears in a second, and I am unable to create a new model for the subsystem. Has anyone faced a similar issue?
Namrita

Hi Namrita,
I think this is a known issue and should be fixed in the next Capella minor release (Capella 1.3.1 in June I assume): I assume that you right-clicked on a Logical Component from a diagram, try it from the project explorer view and it should be working.
Stephane

Hi Stephane,
I tried to do the system to subsystem transition through the project explorer and it worked! Thank you so much!
Regards,
Namrita

Hello Namrita.
I faced the same problem, and I don’t really understand how you solved it.
How do you do the Sys to Sub transition through the project explorer ?
Julien

Hi Julien,
The idea is the following: instead of selecting elements from a diagram and right-clicking to launch the transition, you select the elements from the Capella Project Explorer, ie the tree view window on the left.
Hope this helps
Stéphane

Hi Stéphane
Actually I was getting the ‘Project Explorer’ and the ‘activity explorer’ mixed up.
It worked perfectly, thanks you for your help !
Regards,
Julien

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.