Installation/setup issue

Hi,
I installed the capella 1.2.1 package for windows 64-bit, and downloaded and installed the latest Java package. I am unable to run eclipse.exe, as I get the error window as per the screenshot in the attached. Can someone offer any guidance or help?
Rgds
Ju-Han

Hello Ju-Han,
I ran into the same problem and was able to fix it. Which java version were you using? I downloaded the latest one (jre 1.8.0_161) and was given the error message. To solve it I ended up installing the other jre 1.8.0_162 and it worked!
Hope this works for you as well.
Best,
Daniil

“To solve it I ended up installing the other jre 1.8.0_162 and it worked!”
@Daniil200: Can you explain what you actual did? I now have a similar error with Capella 1.3.1. I’ve just updated Java to the current JRE, 1.8.0_221, and that hasn’t solved my problem.

Hello,
This was a while ago, but I believe I simply downloaded a different/older version of Java. It was a trial and error process to find one though (although it worked on essentially the first older version I tried).
Hope you figure out a way,
Daniil

I found the problem was due to Capella 1.3.1 requiring the 64bit JRE when I only had the 32bit JRE installed. A relatively simple matter of downloading the Java 64 bit installer for my home computer, but this is going to be an issue persuading my employer’s corporate IT to upgrade their 32bit Java deployment to 64bit.

Hi Dave,
Sorry to hear that. It has been a few years now I think that Capella is not built for 32 bits version…
Stéphane

I have Capella 1.2.2 running in a 32 bit JRE on my corporate computer. However, according to the “Platform” table on this page:
https://wiki.polarsys.org/Capella/Roadmap#Platform, Capella 1.2.x is 64 bit! I guess that the Eclipse Neon.3 application platform that Capella 1.2.x uses) is a dual 32/64 bit compatible Java application, whereas the later Eclipse Oxygen (that Capella 1.3.x uses) is purely a 64 bit application.
The reason for all of this is that I was unable to find any of the example models that will load into Capella 1.2.2, and thus had to get the current 1.3.1 version to allow the examples to load.

Hi Dave,
If I am not mistaken, the IFE example is include in the capella zip file under the sample folder for Capella 1.2.2. Are you haing trouble to load this example ?
Stéphane

Sadly the samples folder is missing from the Capella 1.2.2 zip file that I obtained from colleagues in another part of my employers business. I looked in the Polarsys archive for it and didn’t find it.

Hi Dave,
You can download the archive from here:
https://download.eclipse.org/capella/core/products/releases/ 1.2.2-R20181206-153602/?d
but you should experience a faster download from here:
https://s3-eu-west-1.amazonaws.com/obeo-mirror-capella-relea ses/core/platform/releases/1.2.2/neon/capella-1.2.2.20181206 1536-win32-win32-x86_64.zip
I just checked the one for S3 and it does contain the IFE example inside.
All the best,
Stephane LACRAMPE
Obeo

Stephane,
Thank you very much. That is very much appreciated.
Best Regards
Dave B.

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.