Groovy4Capella

Hello Felix,
just a short “ping” about the class-file issue in groovy4capella: were you able to have a look at it and do you have an idea to fix it?

Hi Richard, I just had a quick look and it’s not like I can fix it in 5 minutes. It’s quite an important point though so I’ll keep it in my head. For now, the only thing you can do is to a) put the other classes in your main groovy file, or make a .jar file and put that on the project’s classpath (I think this case works).

Yeah sorry… I should make this work. I understand your other code is also in a .groovy file? Maybe you could try this here:
https://stackoverflow.com/questions/9136328/including-a-groo vy-script-in-another-groovy

Hello Felix,
is the groovy version for Capella-1.3.0 also working with Capella-1.3.1 or do you have to do some adjustments?
Last build is: org.polarsys.capella.groovy-dropins-1.3.0.201812100951.zip

I’d say theres a 70% chance that it should just work. Let me know otherwise… I can’t test this myself now.

Hello Felix,
I just tried and it is still working with Capella-1.3.1.
I only get an error when I start Capella - do you think it is relevant and what may be the cause?

eclipse.buildId=unknown
java.version=1.8.0_221
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Command-line arguments: -os win32 -ws win32 -arch x86_64
org.eclipse.core.filebuffers
Error
Tue Sep 10 09:53:50 CEST 2019
The content type with id “org.eclipse.buildship.core.files.gradlebuildscript” specified in the extension point does not exist.

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.