Changing the "Variable Type" of a Template in M2DOC (incomplete menu) (resolved potentially)

I am surprised to see that whenever i click on “edit” and check the drop-down menu, i can’t find the full list of types.

So my template had this starting variable :

Opening the menu on Edit click, would not offer this choice :
"capellamodeller::SystemEngineering "

It appearts to me that is it offering only variables types which are “lower level” than the starting variable Type (which is here : la::LogicalArchitecture)
It seems i must make a new template in order to be able to choose this “variable Type”.

Is that intentional design? What purpose? Thanks.

The list of available types is build with the list of declared nsURIs in the template. You can modify this list using the template properties wizard. In your case you should add something like:

The version number might change depending on which version of Capella you are using.

An option could be added to the type selection dialog to list all types available in the environment and then add the nsURI automatically if missing. I opened the following issue.

1 Like

Okay for the issue Thanks.

It appears I can’t add “”, let me share my screen :

Is there a problem?

Edit: I think the answer is that all the choices have been selected/imported automatically already, thus the “finish” button not working.

Something is not validating on the next screen of the wizard. It can be:

  • a variable without a type
  • the version number of the M2Doc runtime

You should have a message at the top of the wizard, you can also click the next button to check the points above.

1 Like

Worked thanks.